Udostępnij teraz w social media:

Empathy IM to świetna aplikacja z wieloma świetnymi funkcjami. Jednak brakuje mu w dziale wtyczek. Na szczęście łatwo jest wzmocnić Empathy, pozwalając mu ładować wtyczki Pidgin. W tym samouczku omówimy, jak łatwo jest włączyć wtyczki Pidgin w Empathy. Korzystanie z wtyczek w tej aplikacji jest możliwe dzięki wtyczce Telepathy Haze.

Wtyczki Pidgin w empatii

Postępuj zgodnie z poniższymi instrukcjami, aby dowiedzieć się, jak zainstalować go w swojej dystrybucji Linuksa.

Ubuntu

Wtyczka Telepathy Haze znajduje się w źródłach oprogramowania Ubuntu i istnieje od jakiegoś czasu. Aby zainstalować moduł obsługi wtyczki Purple (Pidgin IM) w systemie Ubuntu Linux, otwórz okno terminala i wprowadź następujące polecenie:

sudo apt install telepathy-haze

Debian

Debian ma wtyczkę Telepathy Haze w źródłach oprogramowania, chociaż może być starsza niż inne dystrybucje Linuksa, ponieważ Debian wolniej aktualizuje pakiety. Nie powinno to mieć wpływu na wtyczki Pidgin, ale miej tego świadomość.

sudo apt-get install telepathy-haze

Arch Linux

Arch Linux jest zawsze aktualny, więc użytkownicy będą mogli zawsze uzyskać absolutnie najnowszą wersję Telepathy Haze na swoim komputerze z systemem Linux. Zainstaluj go z Pacmanem:

sudo pacman -S telepathy-haze

Fedora

Fedora, podobnie jak Arch Linux, jest stosunkowo nowa i ma nowsze pakiety niż większość systemów operacyjnych. Oznacza to, że fani Fedory będą mogli zainstalować absolutnie najnowszą wersję Telepathy Haze.

sudo dnf install telepathy-haze

OpenSUSE

W zależności od używanej wersji OpenSUSE, Twoja wersja Telepathy Haze może się różnić. Aby go zainstalować, otwórz terminal i wprowadź następujące polecenie.

sudo zypper install telepathy-haze

Budowanie ze źródła

Telepatia jest używana praktycznie w każdej dystrybucji Linuksa, więc nie powinno być problemu ze znalezieniem dla niej pakietu. Otwórz okno terminala, wyszukaj hasło „telepathy-haze” i zainstaluj je. W przeciwnym razie postępuj zgodnie z tymi instrukcjami, aby zbudować wtyczkę ze źródła.

Sprawdź -   Jak sprzedać swój stary iPhone za najlepszego dolara

Najpierw pobierz najnowszą wersję kodu źródłowego.

curl https://telepathy.freedesktop.org/releases/telepathy-haze/telepathy-haze-0.8.0.tar.gz > telepathy-haze.tar.gz

Za pomocą polecenia Tar wypakuj pliki z archiwum.

tar -xzvf telepathy-haze.tar.gz
cd telepathy-haze-0.8.0

Używając poleceń cat i more, przeczytaj dołączone pliki INSTALL i README. Przejrzyj je i dowiedz się, jakich zależności potrzebujesz. Zwróć także uwagę na inne instrukcje opisane w tych dokumentach, takie jak ustawienia kompilatora specyficzne dla twojego systemu operacyjnego itp.

cat INSTALL | more

cat README | more

Następnie uruchom skrypt konfiguracyjny i pozwól mu przeskanować i skonfigurować środowisko do kompilacji Telepathy Haze.

./configure

Configure przeskanuje komputer z systemem Linux w poszukiwaniu zależności i błędu, jeśli nie są one zainstalowane. Postaraj się je zainstalować. Konieczne może być sprawdzenie pkgs.org dla paczek.

Sprawdź -   Jak pobrać plik APPX ze sklepu Microsoft Store w systemie Windows 10

Jeśli wszystko wygląda dobrze, zbuduj i zainstaluj Telepathy Haze:

make

sudo make install

Instalowanie komunikatora Empathy

Po zainstalowaniu Telepathy Haze musisz zainstalować samą aplikację Empathy. Podobnie jak Telepathy Haze, jest bardzo dobrze obsługiwany, więc nie powinno być problemu z jego zainstalowaniem.

Ubuntu

Empatia od dawna jest dołączona do Ubuntu. Jeśli jednak Twoja instalacja go nie ma, instalacja jest tak prosta, jak:

sudo apt install empathy

Debian

Debian jest dostarczany z Pidginem do obsługi wiadomości błyskawicznych. Mimo to program Empathy można łatwo zainstalować za pomocą apt-get.

sudo apt-get install empathy

Arch Linux

Podobnie jak Telepathy Haze, użytkownicy Arch mogą pobrać najnowszą wersję Empathy bezpośrednio z repozytoriów oprogramowania. Zainstaluj go przez Pacman:

sudo pacman -S empathy

Fedora

Fedora może już mieć zainstalowaną aplikację Empathy, ponieważ używa wielu programów Gnome. Jeśli jednak używasz alternatywnego pulpitu w Fedorze lub nie możesz znaleźć programu Empathy, zainstaluj go za pomocą DNF:

sudo dnf install empathy

OpenSUSE

Chcesz uzyskać Empathy IM w OpenSUSE? Chwyć go za pomocą menedżera pakietów Zypper:

sudo zypper install empathy

Inne systemy Linux

Empatia to duży program. W rezultacie zbudowanie go ze źródła zajmuje trochę czasu. Na szczęście projekt Gnome ma szczegółowy przewodnik, który dokładnie pokazuje, jak zbudować oprogramowanie komunikatora internetowego. Udaj się na tę stronę tutaj i postępuj zgodnie z nim. Po zainstalowaniu klienta Empathy wróć do przewodnika, aby dowiedzieć się, jak zainstalować wtyczki Pidgin w Empathy.

Sprawdź -   Jak zainstalować Slackware Linux

Instalowanie wtyczek Pidgin w Empathy

Najlepsze w możliwości korzystania z wtyczek Pidgin w programie Empathy IM jest fakt, że użytkownicy nie muszą robić nic specjalnego podczas instalacji. Zamiast tego postępuj zgodnie ze zwykłymi instrukcjami dotyczącymi instalacji wtyczki Pidgin, a Empathy znajdzie plik i załaduje go.

Uwaga: można znaleźć wtyczki Pidgin tutaj.

W tym przykładzie omówimy, jak zainstalować wtyczkę RocketChat Pidgin. Najpierw zainstaluj poprawne zależności wymagane do zbudowania wtyczki.

Uwaga: w tym przykładzie pokazujemy zależności dla Ubuntu, Debiana i Fedory. Aby uzyskać informacje o innych dystrybucjach, zapoznaj się z oficjalnym przewodnikiem.

Ubuntu / Debian

sudo apt install libpurple-dev libjson-glib-dev libglib2.0-dev mercurial make libmarkdown2-dev

Fedora

sudo dnf install libpurple-devel.x86_64 libmarkdown-devel.x86_64 json-glib-devel.x86_64 glib2.x86_64

Za pomocą narzędzia hg pobierz kod źródłowy wtyczki RocketChat:

hg clone https://bitbucket.org/EionRobb/purple-rocketchat/

Umieść płytę CD w sklonowanym folderze purple-rocketchat na komputerze i uruchom polecenie make i wykonaj polecenia instalacji, aby zainstalować wtyczkę.

cd purple-rocketchat

make 

sudo make install

Jeśli wtyczka zostanie pomyślnie zainstalowana, a Telepathy Haze działa, powinieneś być w stanie zobaczyć RocketChat w „Accounts” w Empathy.